faretesto > microsoft.* > microsoft.office.excel

(20.11.2019, 15:49)
Ciao a tutti,

mi sto perdendo in una goccia d'acqua.
Ho il seguente problema.
Ho una serie di dati messi in una colonna del foglio A.
1
2
3
4
5

6
7
8
9
10

11
12
......

siccome sono in verticale, vorrei portarli in orizzontale su un altro
foglio, foglio B, con un collegamento cosi quando cambiano i dati in
colonna, li trovo esatti (in orizzontale) in B.

quindi il risultato finale dovrebbe essere:

1 2 3 4 5
6 7 8 9 10
11 12.....
16 17....

etc...
Questi dati li usero' poi per fare dei grafici.

qualcuno puo' aiutarmi ?
Grazie
Ammammata (20.11.2019, 15:53)
Il giorno Wed 20 Nov 2019 02:49:13p, ** ha inviato su
microsoft.public.it.office.excel il messaggio
news:qr3g8p$rv5$1. Vediamo cosa ha scritto:

> quindi il risultato finale dovrebbe essere:
> 1 2 3 4 5
> 6 7 8 9 10
> 11 12.....
> 16 17....


quindi (tu non lo dici) quelle righe vuote che vedo tra i numeri in
verticale sarebbero degli "a capo" quando le trasponi in orizzontale?

n.b.
sarebbe opportuno spiegare nel dettaglio cosa serve: qui nel gruppo il
possibile lo hanno fatto, l'impossibile lo stanno facendo, ma per i
miracoli stanno ancora organizzandosi
(20.11.2019, 16:13)
"quindi (tu non lo dici) quelle righe vuote che vedo tra i numeri in
verticale sarebbero degli "a capo" quando le trasponi in orizzontale?"

Scusa, hai ragione, mi sono espresso male.
Allora SI, diciamo che nella colonna dove ci sono i valori, lo spazio che
c'è tra il valore 5 e 6, è una riga vuota e comunque, SI, significa che
quando porto i dati nel foglio B, dal 1 al 5 sono su una riga, dal 6 al 10
sono su un'altra riga, etc...
Praticamente è un copiare (verticale) e poi trasponi (incollare nel foglio B
in orizzontale)
Solo che al posto di incollare i dati, vorrei incollare i collegamenti e non
i valori in quanto i valori nel foglio A cambiano.
Spero di esser stato abb. chiaro, altrimenti cerchero' di far meglio...

Nel frattempo un grazie
Ammammata (20.11.2019, 17:09)
Il giorno Wed 20 Nov 2019 03:13:05p, ** ha inviato su
microsoft.public.it.office.excel il messaggio
news:qr3hlm$12j2$1. Vediamo cosa ha scritto:

> Solo che al posto di incollare i dati, vorrei incollare i collegamenti
> e non i valori in quanto i valori nel foglio A cambiano.


(20.11.2019, 17:28)


Ok, grazie.
Avevo detto che mi ero perso in un bicchier d'acqua...per non dire una
goccia.
buonocoreelio (24.11.2019, 02:55)
Il giorno mercoledì 20 novembre 2019 16:28:30 UTC+1, a...@a.it ha scritto:
>
> Ok, grazie.
> Avevo detto che mi ero perso in un bicchier d'acqua...per non dire una
> goccia.


Per AMMAMMATA
Ma la tua non è una soluzione a questo problema che in termini generali è un 'unstacking' di record impilati; nello specifico 6 campi per ogni record con il sesto vuoto. Quello che si richiede è una formula unica che trascinata a destra e verso il basso realizza lo scopo senza quindi la necessità di digitare decine di formule diverse.
Immaginando i dati impilati in colonna A da A1 si può immettere in qualsiasi cella esterna all'intervallo dei dati impilati
=SE.ERRORE(INDICE($A$1:$A$29;(COLONNE($C1:C1)+(RIF .RIGA($A1)-1)*6));"")

da trascinare per altre 4 colonne a destra e poi tenendo selezionate le 5 celle verso il basso fino a quando non sono più visibili dati restituiti

Se i dati devono invece apparire su altro foglio, assumendo che il primo foglio si chiami Foglio1, in qualsiasi cella del foglio di destinazione

=SE.ERRORE(INDICE(Foglio1!$A$1:$A$30;(COLONNE($C1: C1)+(RIF.RIGA($A1)-1)*6));"")

Ciao
Elio
Ammammata (25.11.2019, 09:56)
Il giorno Sun 24 Nov 2019 01:55:54a, ** ha inviato su
microsoft.public.it.office.excel il messaggio
news:fdd02772-05c5-42b7-ac31-4c6e0031d55a. Vediamo cosa
ha scritto:

> Per AMMAMMATA
> Ma la tua non è una soluzione a questo problema che in termini
> generali è un 'unstacking' di record impilati; nello specifico 6
> campi per ogni record con il sesto vuoto. Quello che si richiede è
> una formula unica che trascinata a destra e verso il basso realizza lo
> scopo senza quindi la necessità di digitare decine di formule
> diverse. Immaginando i dati impilati in colonna A da A1 si può
> immettere in qualsiasi cella esterna all'intervallo dei dati impilati
> =SE.ERRORE(INDICE(Foglio1!$A:$A;(COLONNE($C1:C1)+( RIF.RIGA($A1)-1)
> *6));"")


yep!
dato che l'OP aveva problemi anche solo a mettere in riga 4 celle una sopra
l'altra ho messo la tipica "soluzione della serva"

la tua formula (che non ho ancora provato perch? prima devo tradurre in
inglese le funzioni) ? sicuramente un buon esercizio per capire meglio come
sfruttare le potenzialit? di excel
(29.11.2019, 16:59)
=SE.ERRORE(INDICE($A$1:$A$29;(COLONNE($C1:C1)+(RIF .RIGA($A1)-1)*6));"")

da trascinare per altre 4 colonne a destra e poi tenendo selezionate le 5
celle verso il basso fino a quando non sono più visibili dati restituiti

Se i dati devono invece apparire su altro foglio, assumendo che il primo
foglio si chiami Foglio1, in qualsiasi cella del foglio di destinazione

=SE.ERRORE(INDICE(Foglio1!$A$1:$A$30;(COLONNE($C1: C1)+(RIF.RIGA($A1)-1)*6));"")

Ciao
Elio

___________________________

Ciao Elio, grazie infinite.
Era quello che cercavo.
Discussioni simili