faretesto > comp.os.* > comp.os.linux.debian

Puxa_Vida (15.11.2006, 16:45)
Sto provando kubuntu e ho le accentate che non vengono visualizzate nei
programmi che si apoggiano alla shell, mutt, slrn ecc ecc

root@kubuntu:~# locale
LANG=it_IT.UTF-8
LANGUAGE=it_IT:it:en_GB:en
LC_CTYPE="it_IT.UTF-8"
LC_NUMERIC="it_IT.UTF-8"
LC_TIME="it_IT.UTF-8"
LC_COLLATE="it_IT.UTF-8"
LC_MONETARY="it_IT.UTF-8"
LC_MESSAGES="it_IT.UTF-8"
LC_PAPER="it_IT.UTF-8"
LC_NAME="it_IT.UTF-8"
LC_ADDRESS="it_IT.UTF-8"
LC_TELEPHONE="it_IT.UTF-8"
LC_MEASUREMENT="it_IT.UTF-8"
LC_IDENTIFICATION="it_IT.UTF-8"
LC_ALL=

cerco di reconfigurare per aggiungere qualche codifica in modo da vedere
se le accentate, il simbolo euro ecc vengono visualizzati nella shell,
ma non mi da la possibilita'...

root@kubuntu:~# dpkg-reconfigure locales
Generating locales...
en_AU.UTF-8... up-to-date
en_BW.UTF-8... up-to-date
en_CA.UTF-8... up-to-date
en_DK.UTF-8... up-to-date
en_GB.UTF-8... up-to-date
en_HK.UTF-8... up-to-date
en_IE.UTF-8... up-to-date
en_IN.UTF-8... up-to-date
en_NZ.UTF-8... up-to-date
en_PH.UTF-8... up-to-date
en_SG.UTF-8... up-to-date
en_US.UTF-8... up-to-date
en_ZA.UTF-8... up-to-date
en_ZW.UTF-8... up-to-date
it_CH.UTF-8... up-to-date
it_IT.UTF-8... up-to-date
Generation complete.
Current default timezone: 'Europe/Rome'.
Local time is now: mar nov 14 10:43:28 CET 2006.
Universal Time is now: mar nov 14 09:43:28 UTC 2006.
Run 'tzconfig' if you wish to change it.

In genere #dpkg-reconfigure locales mi faceva configurare (su debian
sarge)

grazie
gl (15.11.2006, 17:10)
Il Wed, 15 Nov 2006 15:45:15 +0100, Puxa_Vida ha scritto:
> In genere #dpkg-reconfigure locales mi faceva configurare (su debian
> sarge)


dpkg-reconfigure -p low locales

ciao
gl
Puxa_Vida (15.11.2006, 17:22)
Il 2006-11-15, gl <gl> ha scritto:
> dpkg-reconfigure -p low locales


anche con la priorita' minima non mi fa interagire

root@kubuntu:~# dpkg-reconfigure -p low locales
Generating locales...
en_AU.UTF-8... up-to-date
en_BW.UTF-8... up-to-date
en_CA.UTF-8... up-to-date
en_DK.UTF-8... up-to-date
en_GB.UTF-8... up-to-date
en_HK.UTF-8... up-to-date
en_IE.UTF-8... up-to-date
en_IN.UTF-8... up-to-date
en_NZ.UTF-8... up-to-date
en_PH.UTF-8... up-to-date
en_SG.UTF-8... up-to-date
en_US.UTF-8... up-to-date
en_ZA.UTF-8... up-to-date
en_ZW.UTF-8... up-to-date
it_CH.UTF-8... up-to-date
it_IT.UTF-8... up-to-date
Generation complete.
Current default timezone: 'Europe/Rome'.
Local time is now: mer nov 15 16:22:17 CET 2006.
Universal Time is now: mer nov 15 15:22:17 UTC 2006.
Run 'tzconfig' if you wish to change it.

Grazie
gl (15.11.2006, 18:17)
Il Wed, 15 Nov 2006 16:22:55 +0100, Puxa_Vida ha scritto:
>> dpkg-reconfigure -p low locales

> anche con la priorita' minima non mi fa interagire


Allora rimetti la Sarge :)

ciao
gl
Puxa_Vida (15.11.2006, 18:32)
Il 2006-11-15, gl <gl> ha scritto:
> Allora rimetti la Sarge :)


ahahahah
cerchero' di intervenire sui file di conf per locale ecc, purtroppo
quello dei locale e' il classico argomento che mi sta antipatico e del
quale non ci ho mai capito nulla, infatti non so dove mettere la mani...
grazie

non e' che hai voglia di spendere 2 parole :-) su CUPS?
Non ho ben capito la differenza tra il file PPD e il driver
che la stampante utilizza. Il file PPD, se ho capito bene, descrive i comandi
della stampante, ma non ho capito bene se esso e' legato
indissolubilmente al driver utilizzato, o se il file PPD e' il driver stesso.
Cioe' quando si sta scegliendo un file PPD si sta automaticamente
scegliendo un driver? e se non e' cosi', come si fa a scegliere il
driver da far usare a quella stampante? Ad esempio io ne ho installato
piu' di uno, ma non capisco quale stia usando.

ad esempio se volessi utilizzare i driver cupsys-driver-gimpprint che ho
letto funzionare bene per la mia stampante, che comando dovrei dare?

#lpadmin -p DeskJet840c -E -v parallel:/dev/lp0 - m ?????????????

Lo so che potrei collegarmi alla porta 631 ecc ecc, ma vorrei capirci
qualcosa di piu'
gl (15.11.2006, 18:46)
Il Wed, 15 Nov 2006 17:32:51 +0100, Puxa_Vida ha scritto:
> Il 2006-11-15, gl <gl> ha scritto:
>> Allora rimetti la Sarge :)

> ahahahah


Il mio Ŕ un consiglio onesto e autentico.

> cerchero' di intervenire sui file di conf per locale ecc, purtroppo
> quello dei locale e' il classico argomento che mi sta antipatico e del
> quale non ci ho mai capito nulla, infatti non so dove mettere la mani...
> grazie


il file che cerchi Ŕ /etc/locale.gen

> non e' che hai voglia di spendere 2 parole :-) su CUPS?
> Non ho ben capito la differenza tra il file PPD e il driver
> che la stampante utilizza. Il file PPD, se ho capito bene, descrive i comandi


Non tanta voglia... ma ti scrivo due righe.
Il "driver" in se non esiste, almeno nel concetto di uindovs del termine.
Il PPD descrive le caratteristiche dell'apparato (non i comandi), il
*backend* Ŕ il metodo che lo spooler usa per comunicare i dati alla
stampante.
Questo sarebbe il driver, ma in veritÓ quasi tutti funzionano
appoggiandosi a ghostscript (gs) che si occupa di generare i dati da
inviare alla stampante.
Quindi il driver vero e proprio Ŕ backend+gs.
Gimpprint non l'ho mai usato, dovrebbe essere un altro backend per lo
spooler di CUPS.
In genere mi affido ai PPD di linuxprinting.org e i backend distribuiti
con sarge (cups standard + hpoj)

ciao
gl
Puxa_Vida (15.11.2006, 21:10)
Il 2006-11-15, gl <gl> ha scritto:
> il file che cerchi Ŕ /etc/locale.gen


non c'e', c'Ŕ locale.alias

root@kubuntu:/etc# grep ita locale.alias
italian it_IT.ISO-8859-1

poi credo che gli altri 2 file in gioco siano
/var/lib/locales/supported.d/local

#cat /var/lib/locales/supported.d/local
it_IT.UTF-8 UTF-8
en_US.UTF-8 UTF-8
it_IT ISO-8859-1

ed /etc/environment

# cat /etc/environment
PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games"

###Prima era cosi
#LANG="it_IT.UTF-8"
#LANGUAGE="it_IT:it:en_GB:en"

####Corretto cosi'
LANGUAGE="it_IT:it"
LANG="it_IT.ISO-8859-1"

Qualcuno mi sa dire se basta mettere a posto questi 3 files:
-/etc/locale.alias
-/var/lib/locales/supported.d/local
-/etc/environment

per risolvere il problema?
Puxa_Vida (15.11.2006, 21:25)
Il 2006-11-15, Puxa_Vida <Puxa_Vida> ha scritto:
[..]
> -/etc/locale.alias
> -/var/lib/locales/supported.d/local
> -/etc/environment


mi rispondo da solo: basta, e per come sono configurati i files ora
tutto funziona perfettamente. Comuqne se qualcuno vuole commentare i 3
file (circa l'utilita' ecc) credo rimarra' una bella FAQ su google. Io
ho agito un po' a caso. Credo di aver risolto facendo le correzioni in
/etc/environment che forse setta il charset da utilizzare.
Insomma sono soddisfatto a meta', ho risolto ma non ho ancora capito
bene come funziona la cosa e quali files entrano in gioco.
certo se e' sufficiente agire anche a manina su questi 3 files senza
dover usare altri programmi (dpkg-reconfigure incluso) la cosa e'
abbastanza goduriosa...
Ralph Hinkley (17.11.2006, 05:45)
Puxa_Vida wrote:

> Sto provando kubuntu e ho le accentate che non vengono visualizzate nei
> programmi che si apoggiano alla shell, mutt, slrn ecc ecc


> Il 2006-11-15, Puxa_Vida <Puxa_Vida> ha scritto:


> mi rispondo da solo: basta, e per come sono configurati i files ora
> tutto funziona perfettamente. Comuqne se qualcuno vuole commentare i 3
> file (circa l'utilita' ecc) credo rimarra' una bella FAQ su google.


Visto l'X-No-Archive quoto tutto.
Puxa_Vida (17.11.2006, 10:30)
Il 2006-11-17, Ralph Hinkley <la_posta_di_ralph> ha scritto:
> Visto l'X-No-Archive quoto tutto.


eh ma manca un volenteroso che spieghi come sistemare "l'annosa faccenda
dei locales" agendo solo sui files ;)
Alessio (20.11.2006, 17:46)
On 17 Nov, 09:30, Puxa_Vida <Puxa_V...@kubuntu.manaus> wrote:
> Il 2006-11-17, Ralph Hinkley <la_posta_di_ra> ha scritto:
> > Visto l'X-No-Archive quoto tutto.eh ma manca un volenteroso che spieghi come sistemare "l'annosa faccenda

> dei locales" agendo solo sui files ;)
> --
> Ciao


Ogni volta che lancio dpkg-reconfigure locales guardate che casino
viene fuori..

# dpkg-reconfigure -p low locales
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "it_IT"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or
directory
locale: Cannot set LC_MESSAGES to default locale: No such file or
directory
locale: Cannot set LC_ALL to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_CTYPE to default locale: No such file or
directory
/usr/bin/locale: Cannot set LC_MESSAGES to default locale: No such file
or directory
/usr/bin/locale: Cannot set LC_ALL to default locale: No such file or
directory
gl (20.11.2006, 19:42)
Il Mon, 20 Nov 2006 07:46:29 -0800, Alessio ha scritto:
> /usr/bin/locale: Cannot set LC_ALL to default locale: No such file or
> directory


No such file or directory.
Il pacchetto locales sarÓ installato in parte, oppure un uso errato di
localepurge avrÓ fatto dei danni.

Procederei con un
# apt-get --reinstall install locales

Sperando che il file sources.list non contenga sorgenti di mezzo mondo e
pacchetti incompatibili.

ciao
gl
Discussioni simili