faretesto > linux.debian.user.italian

Filippo Dal Bosco - (10.09.2019, 12:20)
Il giorno Mon, 9 Sep 2019 12:36:35 +0200
Piviul <piviul> ha scritto:

> > bash: dpkg-reconfigure: comando non trovato

> Dunque se non ho capito male sul PC esiste il comando
> /usr/sbin/dpkg-reconfigure. Quindi perché non usi quello per
> riconfigurare il locale? Mi sono perso qualcosa?


in comando

/usr/sbin/dpkg-reconfigure locales

parte con un menu che ti chiede quali vuoi configurare tra i possibili

io ho messo it_IT.utf8, en_GB.utf8 en_US.utf8

poi ti chiede quello di default io ho messo it_IT.utf8

in questo modo hai configurato non solo la lingua ma anche tutti gli
altri parametri locali tipo ( con it_IT.utf8 di default) la virgola
come separatore decimale.

Io vorrei cambiare SOLO la lingua da italiano ad inglese.

ho provato con un editor a modificare in

/etc/default/locale

LANG=en_US.UTF-8

al posto di
LANG=it_IT.UTF-8

ma non cambia solo la lingua, cambia tutto come se di default avessi
messo en_US.utf8

ho provato a mettere in .bashrc e .profile come anche consigliato
in guide trovate in internet

LANG=en_US.utf8
export LANG

LANGUAGE=en_US.utf8
export LANGUAGE

ma non succede nulla.

esiste un metodo per cambiare solo la lingua ?

Probabilmente

LANG=en_US.utf8
export LANG

va fatto in una fase del boot prima del esecuzione del .bashrc della
mia home
valerio (10.09.2019, 13:10)
Il 10/09/19 12:18, Filippo Dal Bosco - ha scritto:
[..]
> altri parametri locali tipo ( con it_IT.utf8 di default) la virgola
> come separatore decimale.
> Io vorrei cambiare SOLO la lingua da italiano ad inglese.


hai provato ad aggiungere a /etc/default/locale

questa lista

[..]
> LC_TELEPHONE="it_IT.utf8"
> LC_MEASUREMENT="it_IT.utf8"
> LC_IDENTIFICATION="it_IT.utf8"


lasciando LC_LANG in inglese?

valerio
Filippo Dal Bosco - (10.09.2019, 13:20)
Il giorno Tue, 10 Sep 2019 13:04:59 +0200
valerio <valerio1950> ha scritto:

> hai provato ad aggiungere a /etc/default/locale
> questa lista
> lasciando LC_LANG in inglese?


attualmente in

/etc/default/locale

ho solo

LANG=it_IT.utf8

è possibile aggiungere quanto sopra ?
valerio (10.09.2019, 13:50)
Il 10/09/19 13:10, Filippo Dal Bosco - ha scritto:
> Il giorno Tue, 10 Sep 2019 13:04:59 +0200
> valerio <valerio1950> ha scritto:
> attualmente in
> /etc/default/locale
> ho solo
> LANG=it_IT.utf8
> è possibile aggiungere quanto sopra ?


sembra:

You might want to use the default en_US locale because some software
doesn't play nice when locale's set to something else, but you want to
have the first day of the week set to Monday, not to Sunday, like it's
defined in en_US. To get this desired behaviour you can add the
following to /etc/default/locale:

LC_TIME="en_GB.UTF-8"

Measuring units and paper size

You might also want to change the measuring units and the paper size if
you're from Europe:

LC_PAPER="en_GB.UTF-8"
LC_MEASUREMENT="en_GB.UTF-8"

valerio
Filippo Dal Bosco - (10.09.2019, 14:00)
Il giorno Tue, 10 Sep 2019 13:47:15 +0200
valerio <valerio1950> ha scritto:

> You might want to use the default en_US locale because some software
> doesn't play nice when locale's set to something else, but you want
> to have the first day of the week set to Monday, not to Sunday, like
> it's defined in en_US. To get this desired behaviour you can add the
> following to /etc/default/locale:


ho fatto cosÌ

LANG=en_US.UTF-8
LANGUAGE=
LC_CTYPE="it_IT.UTF-8"
LC_NUMERIC="itn_IT.UTF-8"
LC_TIME="it_IT.UTF-8"
LC_COLLATE="it_IT.UTF-8"
LC_MONETARY="it_IT.UTF-8"
LC_MESSAGES="it_IT.UTF-8"
LC_PAPER="it_IT.UTF-8"
LC_NAME="it_IT.UTF-8"
LC_ADDRESS="it_IT.UTF-8"
LC_TELEPHONE="it_IT.UTF-8"
LC_MEASUREMENT="it_IT.UTF-8"
LC_IDENTIFICATION="it_IT.UTF-8"
LC_ALL=

ora è in inglese, il separatore decimale virgola, la data ggmmaa

Per le altre variabili vedrò con l' uso
Filippo Dal Bosco - (11.09.2019, 07:50)
Il giorno Tue, 10 Sep 2019 13:47:15 +0200
valerio <valerio1950> ha scritto:


controordine....

ho fatto cosÌ

LANG=en_US.UTF-8
LANGUAGE=
LC_CTYPE="it_IT.UTF-8"
LC_NUMERIC="itn_IT.UTF-8"
LC_TIME="it_IT.UTF-8"
LC_COLLATE="it_IT.UTF-8"
LC_MONETARY="it_IT.UTF-8"
LC_MESSAGES="it_IT.UTF-8"
LC_PAPER="it_IT.UTF-8"
LC_NAME="it_IT.UTF-8"
LC_ADDRESS="it_IT.UTF-8"
LC_TELEPHONE="it_IT.UTF-8"
LC_MEASUREMENT="it_IT.UTF-8"
LC_IDENTIFICATION="it_IT.UTF-8"
LC_ALL=

MA questa mattina fatto il boot ed il linguaggio è italiano !!

Discussioni simili